Author Topic: Issue with Custom build of WM  (Read 1038 times)

0 Members and 1 Guest are viewing this topic.

Offline Randomfish

  • Newbie
  • *
  • Posts: 6
Issue with Custom build of WM
« on: May 22, 2018, 12:08:07 AM »
I'm trying to test out a custom build I made with Visual Studios using only the files provided with the source code download on the download page. However, when I go to debug the game, I get an error saying I'm missing files.

From what I can gather, I'm missing the following files:
ctype.h
assert.h
math.h
corecrt.hstddef.h
time.h
stdio.h

I am a total newb when it comes to coding, so I think I'm missing something that might be an easy fix. Is there something I didn't download? Or is it a problem with my code?

I just updated my copy of Visual Studios, so it's not that I need to update.

Offline aevojoey

  • Hero Member
  • *****
  • Posts: 1413
  • Thats ok, I'm used to disappointment.
Re: Issue with Custom build of WM
« Reply #1 on: May 22, 2018, 08:16:35 PM »
I'm trying to test out a custom build I made with Visual Studios using only the files provided with the source code download on the download page. However, when I go to debug the game, I get an error saying I'm missing files.

From what I can gather, I'm missing the following files:
ctype.h
assert.h
math.h
corecrt.hstddef.h
time.h
stdio.h

I am a total newb when it comes to coding, so I think I'm missing something that might be an easy fix. Is there something I didn't download? Or is it a problem with my code?

I just updated my copy of Visual Studios, so it's not that I need to update.
Those are all system files so the problem is probably not in the game code but in the VS settings.What version of VS are you using?
Fixing the game is a better game than actually playing it.
Get the Current Version <|> Discuss the Game <|> Report a bug

Offline Randomfish

  • Newbie
  • *
  • Posts: 6
Re: Issue with Custom build of WM
« Reply #2 on: May 22, 2018, 08:24:46 PM »
Those are all system files so the problem is probably not in the game code but in the VS settings.What version of VS are you using?

15.7.2. Do I perhaps need to modify my version to accept a particular component?

Offline aevojoey

  • Hero Member
  • *****
  • Posts: 1413
  • Thats ok, I'm used to disappointment.
Re: Issue with Custom build of WM
« Reply #3 on: May 26, 2018, 11:54:59 AM »
15.7.2. Do I perhaps need to modify my version to accept a particular component?
A few links to read:http://forums.codeguru.com/showthread.php?554135-VS-2015-and-standard-headersThat will point you to
https://msdn.microsoft.com/en-us/library/bb531344.aspx#math-h
That should help a little
Fixing the game is a better game than actually playing it.
Get the Current Version <|> Discuss the Game <|> Report a bug